Fudge Fudge
  • Just popping in
  • Just popping in
  • Joined: 13/5 9:46
  • Group: Registered Users
  • Posts: 3
  • Posted on: 13/5 10:02
Treating parasites - Aquacare Antiparasite #1
I'm treating my main tank with Aquacare antiparasite as some (too many for my quarantine tank) of my fish have started flashing (I have checked the water and that's fine). Has anyone used Aquacare antiparasite medication? It said it was safe for all fish, which I naively believed but unfortunately my pleco died overnight. My fish (guppies, swordtails, mollies) are generally more lethargic with the treatment some hovering at the top others at the bottom though they are all happily eatting.

Should I be concerned as I don't want to lose anymore fish? Should I remove the meds with carbon?

Does anyone know how long it will take to work as I'd like to remove the meds as soon as possible. The package doesn't specify, but says you can re-dose after 7 days if necessary. The active ingredients are copper sulphate and formalin.

Many thanks in advance for any advice.
Fishlady Fishlady
  • Tropical Moderator
  • Tropical Moderator
  • Joined: 6/7/2010 19:26
  • From Worcestershire
  • Group: Caresheets Moderators FK Supporter Registered Users Image Admin Advisers
  • Posts: 13624
  • Posted on: 13/5 14:25
Re: Treating parasites - Aquacare Antiparasite #2
From the ingredients it should be a safe medication so I'm surprised you lost a fish. Have you tested for ammonia, nitrite and nitrate? Did you use the correct dose? You need to leave it in for a few days so as the remaining fish are lethargic I wonder if the medication has depleted the oxygen in the tank. Adding an air stone may help.
Fudge Fudge
  • Just popping in
  • Just popping in
  • Joined: 13/5 9:46
  • Group: Registered Users
  • Posts: 3
  • Posted on: 13/5 16:10
Re: Treating parasites - Aquacare Antiparasite #3
Many thanks for your advice Fishlady. I'm please to hear that you don't think it was the medicine as it makes me feel less guilty, but I don't know what else it would be as the pleco showed no signs of anything wrong.
I tested the water before I added the meds and again just now to double check, but they're fine ammonia nil, nitrite nil, nitrate <10 and I've also checked that I dosed according to the instructions. I'm hoping you're right about the oxygen levels - I don't have an air-stone, but I've ordered one to arrive tomorrow. Hopefully that will help.
Thanks
Fishlady Fishlady
  • Tropical Moderator
  • Tropical Moderator
  • Joined: 6/7/2010 19:26
  • From Worcestershire
  • Group: Caresheets Moderators FK Supporter Registered Users Image Admin Advisers
  • Posts: 13624
  • Posted on: 13/5 20:20
Re: Treating parasites - Aquacare Antiparasite #4
You can help with oxygen in the meantime by pointing your filter output at the top of the tank so it ripples the surface.
Fudge Fudge
  • Just popping in
  • Just popping in
  • Joined: 13/5 9:46
  • Group: Registered Users
  • Posts: 3
  • Posted on: 14/5 8:10
Re: Treating parasites - Aquacare Antiparasite #5
Thanks Fishlady I've done that.